Technical Requirements

 

Technical Requirements for Online/Hybrid Learning

Students will need a laptop (PC or Mac) or access to a desktop computer in order to receive the best compatibility and functionality when taking courses at DeSales University. Tablets and mobile phones can be used as supplemental technology but will not have the same capabilities as a full computer.

Requirements for PC

Operating System:  Microsoft Windows 7 or higher

Browser:  Microsoft Internet Explorer (version 11 or higher), Google Chrome (version 58 or higher), or Mozilla Firefox (version 49 or higher). Pop-up blocking should be disabled in all browsers.

Requirements for Mac

Operating System:  Macintosh OS X 10.9 (Mavericks) or higher

Browser:  Safari (version 5.1 or higher), Google Chrome (version 58 or higher), or Mozilla Firefox (version 49 or higher). Pop-up blocking should be disabled in all browsers.

Other Requirements

Hardware: Specific courses require different hardware.  It is the student’s responsibility to find out what hardware is needed to participate in the course. Common hardware includes:

Computer speakers or headset:  Many courses include videos or audio lectures which require use of speakers or a headset

Microphone or headset with microphone:  A microphone may be required if your course includes live audio chat over the Internet.  You can purchase a computer headset with microphone at most office supply or electronics stores.  A USB headset works best with Mac.

Webcam: A camera may be required for video conferencing, secure online testing, and presentation assignments. Cameras that come integrated with laptops work well. External cameras can be purchased online or at office supply and electronics stores.

Software:  Specific courses require different software.  It is the student’s responsibility to find out what software is needed to participate in the course.  MS Office is usually the standard for word processing but any program that will save files as a PDF will work. Adobe Acrobat Reader or some other program that reads PDF files is also often a requirement.

Plug-ins:  A plug-in is a software application that can easily be installed and used as part of your web browser.  In most cases, you will be prompted to install plug-ins as needed.  Some necessary plug-ins may include, but are not limited to the following:

  • Java (version 7 or higher)
  • Microsoft Silverlight
  • Flash Player (version 11 is recommended)
  • Apple QuickTime

E-mail:  Students enrolled in distance education or online courses are required to use their DeSales University e-mail.  Please view the DeSales University e-mail policy on http://www.desales.edu/home/academics/undergraduate-studies/policies-and-procedures.‚Äč